Samstag, 15. Oktober 2016

OS X :create bootable USB device using ISO file

In case you need a  bootable USB stick an you just have an ISO file ...

1.) search for the name of your USB device ( e.g. /dev/disk4) 


diskutil list


2.) convert your iso image to a dmg file
 
hdiutil convert -format UDRW -o yourimage yourimage.iso 

3.)  unmount your USB stick
 
diskutil unmountDisk /dev/disk4 

4) write your DMG to the stick

sudo dd if=yourimage.dmg of=/dev/disk4 bs=10m 

5) unmount your USB stick 

diskutil unmountDisk /dev/disk4